Accessibility

Security bulletin

Security updates available for Adobe Flash Player

Release date: November 6, 2012

Vulnerability identifier: APSB12-24

Priority: See table below

CVE number: CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5278, CVE-2012-5279, CVE-2012-5280

Platform: All Platforms

Summary

Adobe has released security updates for Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh, Adobe Flash Player 11.2.202.243 and earlier versions for Linux, Adobe Flash Player 11.1.115.20 and earlier versions for Android 4.x, and Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and 2.x. These updates address vulnerabilities that could cause a crash and potentially allow an attacker to take control of the affected system.

Adobe recommends users update their product installations to the latest versions:

  • Users of Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh should update to Adobe Flash Player 11.5.502.110.
  • Users of Adobe Flash Player 11.2.202.243 and earlier versions for Linux should update to Adobe Flash Player 11.2.202.251.
  • Flash Player installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 11.5.31.2 for Windows, Macintosh and Linux.
  • Flash Player installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 11.3.376.12 for Windows.
  • Users of Adobe Flash Player 11.1.115.20 and earlier versions on Android 4.x devices should update to Adobe Flash Player 11.1.115.27.
  • Users of Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and earlier versions should update to Flash Player 11.1.111.24.
  • Users of Adobe AIR 3.4.0.2710 and earlier versions for Windows and Macintosh, SDK (including AIR for iOS) and Android should update to Adobe AIR 3.5.0.600.

Affected software versions

  • Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh
  • Adobe Flash Player 11.2.202.243 and earlier versions for Linux
  • Adobe Flash Player 11.1.115.20 and earlier versions for Android 4.x
  • Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and 2.x
  • Adobe AIR 3.4.0.2710 and earlier versions for Windows and Macintosh, SDK (includes AIR for iOS) and Android

To verify the version of Adobe Flash Player installed on your system, access the About Flash Player page, or right-click on content running in Flash Player and select "About Adobe (or Macromedia) Flash Player" from the menu. If you use multiple browsers, perform the check for each browser you have installed on your system.

To verify the version of Adobe Flash Player for Android, go to Settings > Applications > Manage Applications > Adobe Flash Player x.x.

To verify the version of Adobe AIR installed on your system, follow the instructions in the Adobe AIR TechNote.

Solution

Adobe recommends users update their software installations by following the instructions below:

  • Adobe recommends users of Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh update to the newest version 11.5.502.110 by downloading it from the Adobe Flash Player Download Center. Windows and Macintosh users can also install the update via the update mechanism within the product when prompted.
  • For users of Flash Player 10.3.183.29 and earlier versions for Windows and Macintosh, who cannot update to Flash Player 11.5.502.110, Adobe has made available the update Flash Player 10.3.183.43, which can be downloaded here.
  • Adobe recommends users of Adobe Flash Player 11.2.202.243 and earlier versions for Linux update to Adobe Flash Player 11.2.202.251 by downloading it from the Adobe Flash Player Download Center.
  • For users of Flash Player 11.2.202.243 and earlier versions for Linux, who cannot update to Flash Player 11.2.202.251, Adobe has made available the update Flash Player 10.3.183.43, which can be downloaded here.
  • Flash Player installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 11.5.31.2 for Windows, Macintosh and Linux.
  • Flash Player installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 11.3.376.12 for Windows.
  • Users of Adobe Flash Player 11.1.115.20 and earlier versions on Android 4.x devices should update to Adobe Flash Player 11.1.115.27*.
    * Note: Applicable only for Android 4.x devices with Flash Player installed prior to August 15, 2012.
  • Users of Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and earlier versions should update to Flash Player 11.1.111.24*.
    * Note: Applicable only for Android 3.x devices and earlier with Flash Player installed prior to August 15, 2012.
  • Users of Adobe AIR 3.4.0.2710 for Windows and Macintosh should update to Adobe AIR 3.5.0.600.
  • Users of the Adobe AIR 3.4.0.2710 SDK (includes AIR for iOS) should update to the Adobe AIR 3.5.0.600 SDK.
  • Users of the Adobe AIR 3.4.0.2710 and earlier versions for Android should update to Adobe AIR 3.5.0.600 by browsing to Google Play or the Amazon Marketplace on an Android device.

Priority and Severity ratings

Adobe categorizes these updates with the following priority ratings and recommends users update their installations to the newest versions:

Product
Updated Version
Platform
Priority Rating
Adobe Flash Player 11.5.502.110 Windows
1
  11.5.502.110 Macintosh
2
  11.2.202.251 Linux
3
  11.1.115.27 Android 4.x
3
  11.1.111.24 Android 3.x and 2.x
3
Adobe AIR 3.5.0.600 Windows and Macintosh
3
  3.5.0.600 SDK (including AIR for iOS) and Android
3


These updates address critical vulnerabilities in the software.

Details

Adobe has released security updates for Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh, Adobe Flash Player 11.2.202.243 and earlier versions for Linux, Adobe Flash Player 11.1.115.20 and earlier versions for Android 4.x, and Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and 2.x. These updates address vulnerabilities that could cause a crash and potentially allow an attacker to take control of the affected system.

Adobe recommends users update their product installations to the latest versions:

  • Users of Adobe Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh should update to Adobe Flash Player 11.5.502.110.
  • Users of Adobe Flash Player 11.2.202.243 and earlier versions for Linux should update to Adobe Flash Player 11.2.202.251.
  • Flash Player installed with Google Chrome will automatically be updated to the latest Google Chrome version, which will include Adobe Flash Player 11.5.31.2 for Windows, Macintosh and Linux.
  • Flash Player installed with Internet Explorer 10 will automatically be updated to the latest Internet Explorer 10 version, which will include Adobe Flash Player 11.3.376.12 for Windows.
  • Users of Adobe Flash Player 11.1.115.20 and earlier versions on Android 4.x devices should update to Adobe Flash Player 11.1.115.27.
  • Users of Adobe Flash Player 11.1.111.19 and earlier versions for Android 3.x and earlier versions should update to Flash Player 11.1.111.24.
  • Users of Adobe AIR 3.4.0.2710 for Windows and Macintosh, SDK (including AIR for iOS) and Android should update to Adobe AIR 3.5.0.600.

These updates resolve buffer overflow vulnerabilities that could lead to code execution (CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5280).

These updates resolve memory corruption vulnerabilities that could lead to code execution (CVE-2012-5279).

These updates resolve a security bypass vulnerability that could lead to code execution (CVE-2012-5278).

Affected software

Recommended player update

Availability

Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh

11.5.502.110

Flash Player Download Center

Flash Player 11.4.402.287 and earlier versions for Windows and Macintosh -
network distribution

11.5.502.110

Flash Player Licensing

Flash Player 11.2.202.243 and earlier for Linux

11.2.202.251

Flash Player Download Center

Flash Player 11.1.115.20 and earlier for Android 4.x

11.1.115.27

Applicable only for Android 4.x devices with Flash Player installed prior to August 15, 2012.

Flash Player 11.1.111.19 and earlier for Android 3.x and 2.x

11.1.111.24

Update to devices that already have Flash Player installed prior to August 15, 2012.

Flash Player 11.4.402.287 and earlier for Chrome users
(Windows and Linux)

11.5.31.2

Google Chrome Releases

Flash Player 11.4.402.287 and earlier for Chrome users
(Macintosh)

11.5.31.2

Google Chrome Releases

Flash Player 11.3.375.10 and earlier in Internet Explorer 10

11.3.376.12

Windows Download Center

AIR 3.4.0.2710 and earlier for Windows and Macintosh

3.5.0.600

AIR Download Center

AIR 3.4.0.2710 SDK (includes AIR for iOS) and earlier

3.5.0.600

AIR SDK Download

AIR 3.4.0.2710 and earlier for Android

3.5.0.600

Google Play
(browse to on an Android device)
Amazon Marketplace

(browse to on an Android device)

 

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers:

  • Mateusz Jurczyk, Gynvael Coldwind, and Fermin Serna of the Google Security Team (CVE-2012-5274, CVE-2012-5275, CVE-2012-5276, CVE-2012-5277, CVE-2012-5279, CVE-2012-5280)
  • Eduardo Vela Nava of the Google Security Team (CVE-2012-5278)