Accessibility
Adobe
Sign in Privacy My Adobe

Security bulletin

Security updates available for Shockwave Player

Release date: November 3, 2009

Vulnerability identifier: APSB09-16

CVE number: CVE-2009-3244, CVE-2009-3463, CVE-2009-3464, CVE-2009-3465, CVE-2009-3466

Platform: Windows and Macintosh

Summary

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.1.601 and earlier versions. The vulnerabilities could allow an attacker, who successfully exploits the vulnerabilities, to run malicious code on the affected system. Adobe has provided a solution for the reported vulnerabilities. It is recommended that users update their installations using the instructions provided below.

Affected software versions

Shockwave Player 11.5.1.601 and earlier versions

Solution

Adobe recommends Shockwave Player users install Shockwave Player version 11.5.2.602 available here: http://get.adobe.com/shockwave/.

Severity rating

Adobe categorizes this as a critical update and recommends that users apply the update for their product installations.

Details

Critical vulnerabilities have been identified in Adobe Shockwave Player 11.5.1.601 and earlier versions. The vulnerabilities could allow an attacker, who successfully exploits the vulnerabilities, to run malicious code on the affected system. Adobe has provided a solution for the reported vulnerabilities.

This update resolves an invalid index vulnerability that could potentially lead to code execution (CVE-2009-3463).

This update resolves invalid pointer vulnerabilities that could potentially lead to code execution (CVE-2009-3464, CVE-2009-3465).

This update resolves an invalid string length vulnerability that could potentially lead to code execution (CVE-2009-3466).

This update resolves a boundary condition issue that could lead to a Denial of Service (DoS) issue (CVE-2009-3244).

Acknowledgments

Adobe would like to thank the following individuals and organizations for reporting the relevant issues and for working with Adobe to help protect our customers' security:

  • Nicolas Joly of VUPEN Security (CVE-2009-3463, CVE-2009-3464, CVE-2009-3465, CVE-2009-3466)